While some of the issues usually go away after you give it another try, some of the connection failures cause an error, like this one:

Image showing error message:

We noticed that these errors are usually caused by difficulties with:

  1. SMTP (outgoing server): a protocol that is used to send your messages.

  2. IMAP (incoming server): a protocol responsible for fetching your replies.

  3. Data provided: your credentials.


Learn more about IMAP & SMTP on our blog here »


How to fix connection errors:

1. SMTP

Is your mailbox brand new perhaps? Did you create it just today or a couple of days ago? If the answer is yes:

  • Send a couple of messages (at least 5) manually to your friends or colleagues.

  • Ask them to send you a reply.

This process establishes a connection between your hosting server and the servers of other email providers. Remember to warm up your email address before you start your campaign. Learn how to do the warm-up process from our article »

2. IMAP

  • Please check if your mailbox has IMAP enabled. If not, switch it on. If you have a Gmail account, here's how to do this »

  • Is there any forwarding enabled on the email account? If yes, switch it off. Here's why you should do that »

  • Is there any labeling or redirecting to a different folder? This also has to be switched off.

  • In case there's 2-step verification enabled on your mailbox, please disable it for the time of connecting the mailbox.

  • Does our message land in the SPAM or junk folder? If yes, please move it to Inbox.

  • In case you're an Agency owner, have a look at your client's SPAM folder as your email may have landed there. Move it to the Inbox. You can also add your domain to the safe contacts.

3. Your details and data provided (login, password, IMAP & SMTP ports)

  • Please make sure your login & password are correct.

  • Besides, double-check the provided IMAP and SMTP server data. Try adding ports. For IMAP try adding port 993, for SMTP use ports 465 (most common) or 587. Port 25 usually doesn't work.

  • Make sure you're not connecting Woodpecker through POP3, as this won't work.


You've gone through all the options yet still struggling with connecting your email account? Other reasons might be:

  • Your mailbox hasn't been configured and authenticated properly. For Microsoft accounts, check their help page »

  • Your mailbox has been already connected. Check the list of your connected email accounts. Go to Settings → Email accounts.

  • The main mailbox on the Agency account has been disconnected. Go to Settings Email accounts and reconnect your mailbox.

  • An alias that you're trying to add hasn't been configured correctly.


Did this answer your question?